匿名手順

概要

名前が付けられていない手順を表すオブジェクトです。

匿名手順では、他の手順の引数として手順そのものを渡すことができます。

スミレ

作成する方法

匿名手順を作るには、ブロックを表す記号『 』を使います。
プログラムを『 』で囲うことで匿名手順を作ることができます。
匿名手順は、他の式と同様に手順の引数として指定したり、変数に代入したりできます。

『【プログラム】』

手順

次の手順が使用できます。

【自分】を実行する基本物

匿名手順にあるプログラムを実行します。

戻り値:匿名手順を実行したときの戻り値を返します。戻り値がない時は、無を返します。

【自分】を【引数一覧】で実行する:基本物

(現在は利用できません)匿名手順にあるプログラムを実行します。

引数一覧:匿名手順に指定する値を配列で指定します。

戻り値:匿名手順を実行したときの戻り値を返します。戻り値がない時は、無を返します。

設定項目

次の設定項目が使用できます。

設定項目   説明
内容 文字列 プログラムの内容を文字列で表します。

記号の意味

サンプルコード

匿名手順を生成して呼び出す

匿名手順を定義して、特定の条件で処理を切り替えます。

3回、値を1から増やしながら繰り返す
	『「第[値]回」を表示する』を処理する
	『「[値]回目」を表示する』を処理する
繰り返し終わり

【対象プログラム】を、処理する手順
	対象プログラムを実行する
終わり

ページ先頭へ