困ったときは

ミスを捜すデバッグ

ソフトを作りはじめると、ミスがたくさん見つかります。
少しのプログラムであれば、命令を一行一行、確認すれば良いのですが、
プログラムが大きくなると何千行にもなり、一つ一つ確認するわけには行きません。

また、プログラムが複雑になるとエラーメッセージが表示される部分に
問題があるとは限らず、他の部分が原因でうまく動かなくこともあります。
そもそもエラーが起こらない場合もあります。

ここでは、「ミスを見つけて、修正する」=『デバッグ』という作業について説明します。

 

「表示する」手順を使う

ミスを確認する方法として、一番簡単なのが、
「表示する」「報告する」手順を使う方法です。

例えば、次のようなプログラムがうまく動かず、困っているとします。

もし今日が、「2010年1月1日」なら
	「明けましておめでとう」を表示する
もし終わり

一見すると、正しいプログラムのように見えますが、
今日の日付が2010年1月1日にもかかわらず、思った通りに正しく実行されません。

そこで、2行目に次のプログラムを書き足します。

今日を表示する

実行すると、「2010/01/01 0:00:00」と表示されます。

つまり、「もし」で判断するときに、「2010年1月1日」ではなく
「2010/01/01 0:00:00」などとしないと正しく動作しないことが分かります。

このように、表示命令を使って内容を確認することで、
上手く動かない原因を調べることができます。

 

調査ウィンドウを使う

「調査ウィンドウ」では、変数の現在の状態や手順の実行状況などを見ることができます。

変数の内容を確認する

調査ウィンドウを使えば、「表示する」手順を使わずに、変数の内容を調べることができます。

例えば、次のようなプログラムを実行してみてください。

数値は、10
メッセージは、「これが調査ウィンドウです。」
「[メッセージ][改行]“変数”タブをクリックしてね」を報告する

実行すると、調査ウィンドウに、メッセージが表示されます。

上の「変数」ボタンで切り替えると、変数の一覧とその中身を確認することができます。

 

停止行を設定する

最後に、プログラム実行中に、好きな場所で一時停止する機能を紹介します。

問題のあるプログラムの一時停止したい行にカーソルを置いて、F9を押すと、その行の色が変わります。再びF9を押すと解除されます。

停止行が設定された部分は、赤く強調されます。

この状態でプログラム実行すると、この行に到達したときにプログラムを一時停止します。

止まった次のプログラムを実行するには、F5を押します。

「調査ウィンドウ」と組み合わせれば、その時点での変数の内容を見ることができるので、ミスを見つけるのに必要な情報を得ることができます。

ページ先頭へ