判断文

指定した判断式に応じて、処理を分岐するには、「もし」文を使います。

判断文の書き方

判断文は、次のような書式で書きます。

書式

もし《条件》なら /* 正しい時の文  */ でなければ /* 違う時の文 */
もし《条件》なら
  /* 条件が正しいときに実行する文 */
もし終わり
《条件》

判断する条件式を書きます。
または、真偽値を書くこともできます。

条件が正しくない場合

条件式が正しくないときに、実行するプログラムを書くことができます。

書式 条件が正しくない

もし《条件》なら
   /* 条件が正しいときに実行する文 */
そうでなければ
   /* 条件が違うときに実行する文 */
もし終わり

条件が違った時に、次の条件について判断させることもできます。

書式 複数条件分岐

もし《条件》なら
  /* 条件が正しいときに実行する文 */
他でもし《条件》なら
  /* 最初の条件が違い、次の条件が正しいときに実行する文 */
そうでなければ
  /* すべての条件が違うときに実行する文 */
もし終わり

※「そうでなければ」のほか、「でないなら」、「他なら」と書くこともできます

例文 文字列の判断

メッセージは、「こんにちは」
 
もしメッセージが「こんにちは」なら
  「正しい」を表示する
そうでなければ
  「違います」を表示する
もし終わり

条件式によって処理を分岐する

他でもし”を使うことで、条件に合致しない場合にさらに特定の条件で、実行するプログラムを書くことができます。

数字は、1
もし数字が1なら
  ーー1の時
  処理1
他でもし数字が2なら
  ーー2の時
  処理2
でないなら
  ーーそれ以外の時
  処理3
もし終わり

例文 数値の比較

正解は、123
数字は、入力画面で「数値を入力してください」を入力したもの

もし数字が正解なら
  「正しい」を表示する
他でもし数字が正解より大きいなら
  「[数字]より小さい」を表示する
他でもし数字が正解より小さいなら
  「[数字]より大きい」を表示する
もし終わり

条件式を数学表記で書くこともできます。

正解は、123
数字は、入力画面で「数値を入力してください」を入力したもの
 
もし数字=正解なら
  「正しい」を表示する
他でもし数字≧正解なら
  「[数字]より小さい」を表示する
他でもし数字≦正解なら
  「[数字]より大きい」を表示する
もし終わり

条件の書き方

書くことができる条件式は、次のようになります。

条件式

優先度 条件式の表記 意味

□=◇ □と◇が等しい
  □≠◇ □と◇が等しくない
  □>◇ □が◇より大きい
  □<◇ □が◇より小さい
  □≧◇ □が◇以上
  □≦◇ □が◇以下
  【条件式】でない 【条件式】が正しくない
  □が◇ □と◇が等しい
  □が◇より大きい □が◇より大きい (□>◇と同じ)
  □が◇より小さい
□が◇未満
□が◇より下
□が◇より小さい (□<◇と同じ)
  □が◇以上 □が◇以上 (□≧◇と同じ)
  □が◇以下 □が◇以下 (□≦◇と同じ)
  《条件式1》または《条件式2》
《条件式1》あるいは《条件式2》
《条件1》か《条件2》のどちらかが正しい

《条件式1》かつ《条件式2》 《条件1》と《条件2》のどちらも正しい

※“□◇”の代わりに“□が、◇”、“□は、◇”と書くこともできます。

2つ以上の条件を同時に判断する

「かつ」と「または」を使って複数の条件を書くことができます。
( )で囲うこともできます。

例文

数字1は 1
数字2は 2

ーーすべての式が正しい時(And)
もし数字1が1かつ数字2が1なら、「どっちも正しい」を表示する

ーーどれかの式が正しい時(Or)
もし(数字1が1)または(数字2が3)なら、「どっちか正しい」を表示する

ページ先頭へ